<!DOCTYPE html><html lang="en" data-reactroot=""><head><meta name="google-site-verification" content="E8XcSciqzOAn75mK4Fj5hdxYRX2_cO2abaYZrl2KrjQ"/><meta name="google-site-verification" content="QDPLbDJXTQNT0n69mvNADCeRmwnbkYyL20OKJAVCKq8"/><meta name="ir-site-verification-token" value="-1270174611"/><meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0,maximum-scale=10.0"/><meta charSet="utf-8"/><meta name="ROBOTS" content="INDEX, FOLLOW"/><title>Damian Lillard declares himself NBA’s second-best shooter ever</title><link rel="shortcut icon" type="image/png" href="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/rnxqtvv6advgidzfs6am.png"/><link rel="apple-touch-icon" type="image/png" href="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/rnxqtvv6advgidzfs6am.png"/><meta name="msapplication-square70x70logo" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/rnxqtvv6advgidzfs6am.png"/><meta name="msapplication-square150x150logo" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/rnxqtvv6advgidzfs6am.png"/><link rel="dns-prefetch" href="//kinja.com"/><link rel="dns-prefetch" href="//i.kinja-img.com"/><link rel="dns-prefetch" href="//x.kinja-static.com"/><link rel="dns-prefetch" href="//f.kinja-static.com"/><link rel="dns-prefetch" href="//www.googletagservices.com"/><link rel="dns-prefetch" href="//pubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//stats.g.doubleclick.net"/><link rel="dns-prefetch" href="//tpc.googlesyndication.com"/><link rel="dns-prefetch" href="//pagead2.googlesyndication.com"/><link rel="dns-prefetch" href="//adservice.google.com"/><link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="https://ir-na.amazon-adsystem.com"/><link rel="dns-prefetch" href="https://fls-na.amazon-adsystem.com"/><link rel="dns-prefetch" href="//imasdk.googleapis.com"/><link rel="dns-prefetch" href="//tps10232.doubleverify.com"/><link rel="dns-prefetch" href="//c.amazon-adsystem.com"/><link rel="dns-prefetch" href="//aax.amazon-adsystem.com"/><link rel="preconnect" href="https://c.amazon-adsystem.com" crossorigin="anonymous"/><link rel="dns-prefetch" href="//www.google-analytics.com"/><link rel="dns-prefetch" href="//cdn.speedcurve.com"/><link rel="preconnect" href="https://i.kinja-img.com"/><link rel="preconnect" href="//x.kinja-static.com"/><link rel="preconnect" href="//f.kinja-static.com" crossorigin=""/><link rel="preconnect" href="//cdn.speedcurve.com" crossorigin=""/><link rel="preload" href="https://f.kinja-static.com/assets/fonts/proxima/proxima_nova_cond_reg-webfont.woff2?08252015" as="font" type="font/woff2" crossorigin=""/><link rel="preload" href="https://f.kinja-static.com/assets/fonts/proxima/proxima_nova_cond_reg_it-webfont.woff2?08252015" as="font" type="font/woff2" crossorigin=""/><link rel="preload" href="https://f.kinja-static.com/assets/fonts/proxima/proxima_nova_cond_sbold-webfont.woff2?08252015" as="font" type="font/woff2" crossorigin=""/><link rel="preload" href="https://f.kinja-static.com/assets/fonts/proxima/proxima_nova_cond_sbold_it-webfont.woff2?08252015" as="font" type="font/woff2" crossorigin=""/><link rel="alternate" type="application/rss+xml" title="Deadspin - All stories" href="https://deadspin.com/rss"/><meta name="keywords" content="NBA, National Basketball Association, Young, allen s, Clyde Drexler, Kyrie Irving, Reggie Miller, Steve Nash, Larry Bird, Steph Curry, the NBA, Sportspeople, Damian Lillard, Victor Wambanyama, Wardell, Stephen Curry, Kevin Durant, Ray Allen, Deadspin"/><meta name="news_keywords" content="NBA, National Basketball Association, Young, allen s, Clyde Drexler, Kyrie Irving, Reggie Miller, Steve Nash, Larry Bird, Steph Curry, the NBA, Sportspeople, Damian Lillard, Victor Wambanyama, Wardell, Stephen Curry, Kevin Durant, Ray Allen, Deadspin"/><meta name="twitter:url" content="https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545"/><meta property="article:published_time" content="2022-12-20T21:06:00.545Z"/><link rel="canonical" href="https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545"/><meta name="description" content="Dame is really good, but come on, is he that good?"/><meta property="og:title" content="Lillard nominating himself as the second-best shooter in NBA history was the ultimate heat check"/><meta property="og:type" content="article"/><meta name="author" content=""/><meta property="og:url" content="https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545"/><meta property="og:description" content="Dame is really good, but come on, is he that good?"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Deadspin"/><meta property="og:image" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_675,pg_1,q_80,w_1200/5093af871630a224159981c51d6d1d7f.jpg"/><meta property="fb:app_id" content="49024928184"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="deadspin"/><meta name="twitter:title" content="Lillard nominating himself as the second-best shooter in NBA history was the ultimate heat check"/><meta name="twitter:description" content="Dame is really good, but come on, is he that good?"/><meta name="twitter:image" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_675,pg_1,q_80,w_1200/5093af871630a224159981c51d6d1d7f.jpg"/><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TH42LHK');</script></script><script async="" src="//js-sec.indexww.com/ht/p/183957-47751755686051.js"></script><script>
					window.headertag = window.headertag || {};
					window.headertag.cmd = window.headertag.cmd || [];
					window.headertag.cmd.push(function() {
					var rtiData = window.headertag.getIdentityInfo();

					var responsePending = 0;
					for (var rtiPartner in rtiData) {
						if (rtiData.hasOwnProperty(rtiPartner) && rtiData[rtiPartner].responsePending === true) {
							responsePending = 1;
							break;
						}
					}

					// Subscribe if response is pending
					if (responsePending) {
						window.headertag.subscribeEvent('rti_partner_request_complete', false, function(eventName, eventData) {
							rtiData = window.headertag.getIdentityInfo();
						})
					}
					});</script><script id="kinja-data" type="application/json">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</script><script>
				const kinjaDataElement = document.getElementById('kinja-data');
				window.kinja = kinjaDataElement && JSON.parse(kinjaDataElement.textContent || kinjaDataElement.innerText) || {};
			</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');</script><script>LUX=(function(){var a=("undefined"!==typeof(LUX)&&"undefined"!==typeof(LUX.gaMarks)?LUX.gaMarks:[]);var d=("undefined"!==typeof(LUX)&&"undefined"!==typeof(LUX.gaMeasures)?LUX.gaMeasures:[]);var j="LUX_start";var k=window.performance;var l=("undefined"!==typeof(LUX)&&LUX.ns?LUX.ns:(Date.now?Date.now():+(new Date())));if(k&&k.timing&&k.timing.navigationStart){l=k.timing.navigationStart}function f(){if(k&&k.now){return k.now()}var o=Date.now?Date.now():+(new Date());return o-l}function b(n){if(k){if(k.mark){return k.mark(n)}else{if(k.webkitMark){return k.webkitMark(n)}}}a.push({name:n,entryType:"mark",startTime:f(),duration:0});return}function m(p,t,n){if("undefined"===typeof(t)&&h(j)){t=j}if(k){if(k.measure){if(t){if(n){return k.measure(p,t,n)}else{return k.measure(p,t)}}else{return k.measure(p)}}else{if(k.webkitMeasure){return k.webkitMeasure(p,t,n)}}}var r=0,o=f();if(t){var s=h(t);if(s){r=s.startTime}else{if(k&&k.timing&&k.timing[t]){r=k.timing[t]-k.timing.navigationStart}else{return}}}if(n){var q=h(n);if(q){o=q.startTime}else{if(k&&k.timing&&k.timing[n]){o=k.timing[n]-k.timing.navigationStart}else{return}}}d.push({name:p,entryType:"measure",startTime:r,duration:(o-r)});return}function h(n){return c(n,g())}function c(p,o){for(i=o.length-1;i>=0;i--){var n=o[i];if(p===n.name){return n}}return undefined}function g(){if(k){if(k.getEntriesByType){return k.getEntriesByType("mark")}else{if(k.webkitGetEntriesByType){return k.webkitGetEntriesByType("mark")}}}return a}return{mark:b,measure:m,gaMarks:a,gaMeasures:d}})();LUX.ns=(Date.now?Date.now():+(new Date()));LUX.ac=[];LUX.cmd=function(a){LUX.ac.push(a)};LUX.init=function(){LUX.cmd(["init"])};LUX.send=function(){LUX.cmd(["send"])};LUX.addData=function(a,b){LUX.cmd(["addData",a,b])};LUX_ae=[];window.addEventListener("error",function(a){LUX_ae.push(a)});LUX_al=[];if("function"===typeof(PerformanceObserver)&&"function"===typeof(PerformanceLongTaskTiming)){var LongTaskObserver=new PerformanceObserver(function(c){var b=c.getEntries();for(var a=0;a<b.length;a++){var d=b[a];LUX_al.push(d)}});try{LongTaskObserver.observe({type:["longtask"]})}catch(e){}};</script><script src="https://cdn.speedcurve.com/js/lux.js?id=527761496" async="" defer="" crossorigin="anonymous"></script><script async="">
						LUX = window.LUX || {};
						if (LUX.length !== 0) {
							LUX.label = 'article';
							LUX.addData('page-url', window.location.href);
						}
					</script><script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script async="">var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];</script><script src="https://tagan.adlightning.com/gomedia/op.js" defer=""></script><script type="module" src="/x-kinja-static/assets/new-client/runtime~adManager.69f36eb7466b8c3b4764.js"></script><script type="module" src="/x-kinja-static/assets/new-client/vendor~adEditor~adManager~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPa~cac44946.2ed8aad3bc636efb72b1.js"></script><script type="module" src="/x-kinja-static/assets/new-client/adManager~video-html5-playlist~videoHtml5.5692c66df45b83651100.js"></script><script type="module" src="/x-kinja-static/assets/new-client/adManager.1782a3caa57730d39fe4.js"></script><script type="module" src="/x-kinja-static/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~bc21b349.ab86979842b2d0b186fc.js"></script><script type="module" src="/x-kinja-static/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~9c9b1d7c.905d3d5454a9ad56359d.js"></script><script type="module" src="/x-kinja-static/assets/new-client/adEditor~biztoolsPage~carSpecsPage~commerceDashboard~curatedHomepage~curatedPostsPage~datadog~errorP~f0afce4b.ec655ce46e257b10293b.js"></script><script type="module" src="/x-kinja-static/assets/new-client/runtime~videoHtml5.d72264a7f7dd8df0a27f.js"></script><script type="module" src="/x-kinja-static/assets/new-client/vendor~video-html5-playlist~videoHtml5.100c6d4f3072d862c740.js"></script><script type="module" src="/x-kinja-static/assets/new-client/video-html5-playlist~videoHtml5.c4066993b3483f5b0321.js"></script><script type="module" src="/x-kinja-static/assets/new-client/videoHtml5.c76f793545145fdbefd3.js"></script><script>
				window._user = new Promise((resolve, reject) => {
					window._fasttoken = function (response) {
						if (response && response.meta &&response.meta.status === 200) {
							resolve(response.data);
						} else {
							reject(response ? response.meta : '');
						}
					};
				});
			</script><script src="https://kinja.com/api/profile/accountwithtoken?jsonp=_fasttoken&amp;newFollows=true" defer=""></script><script>
					window.blockthrough = window.blockthrough || { aa_detect_cmd: [] };
				</script><style data-styled="" data-styled-version="5.1.0">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</style><style>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</style></head><body class="deadspin blog-group-deadspin blog-recirc-group-fmgNonSatire permalink en-US f_ad_lightning_tag_on f_ad_refresh_enabled_on f_ad_script_in_head_on f_ad_timeout_amazon_on f_ad_timeout_failsafe_on f_ad_timeout_prebid_on f_alerts_sidebar_on f_amazon_aps_tag_on f_amazon_related_link_on f_amp_enable_t13_on f_amp_slideshow_on f_amp_sticky_ad_on f_amp_video_extra_events_on f_analyticstracking_on f_author_page_canonical_on f_breadcrumbs_use_schemaorg_on f_cls_on f_cls_mobile_inpost_on f_collapsed_top_ad_on f_crop_modal_align_on f_curated_homepage_on f_custom_ad_sizes_on f_ddrum_on f_disable_amp_on f_disable_lazy_mfn_on f_disable_lazy_ymal_on f_disguise_video_links_as_videos_on f_eager_load_ga_on f_editor_unload_3rdparty_on f_enable_bouncex_on f_enable_html_sitemap_on f_fastly_location_header_on f_featured_ads_four_on f_filter_kinja_meta_on f_fivecardcarousel_on f_frontendtiming_on f_frontpage_recentvideo_on f_frontpage_sticky_leaderboard_on f_global_video_page_on f_goauthorurl_on f_hide_sticky_social_on f_homepage_layout_admin_only_on f_homepage_sticky_ads_4s_on f_hp_smaller_images_on f_ignore_commerce_disclaimer_on f_infinite_promotion_on f_infinite_scroll_on f_ix_identity_tag_on f_kargo_amp_on f_lazyload_iframes_on f_lazyload_twitter_iframe_on f_lazyload_youtube_iframe_on f_magnite_segments_on f_merge_price_vendor_on f_missing_image_alts_on f_movable_ads_tool_shift_fix_on f_newsletter_inline_form_enabled_on f_newsletter_modal_subdomain_on f_newsletter_popup_exit_intent_on f_newsletter_popup_exit_intent_mobile_on f_prebid_on f_prebid_analytics_on f_prebid_ias_enable_on f_prebid_resetdigital_on f_refresh_25_seconds_on f_refresh_ads_in_view_on f_related_stories_inset_on f_remove_h_tags_from_sidebar_on f_remove_sticky_h1_on f_section_nav_ga_events_on f_short_whitelisted_check_on f_show_splashy_top_on f_sidebar_ad_whitespace_on f_slideshow_on f_sourcepoint_ccpa_on f_sourcepoint_header_on f_sourcepoint_keyval_on f_speedcurve_lux_on f_sportradar_widget_on f_sticky_right1_ad_on f_su_manage_blog_dropdown_on f_survey_popup_permalink_on f_tag_noindex_nofollow_on f_taxonomy_on f_trackonomics_amp_on f_truncate_permalink_content_on f_truncate_sidebar_on f_veritas_compression_on f_veritas_tracker_on f_video_permalink_play_next_on f_video_thumbnail_fix_on f_welcome_ad_analytics_on f_welcome_ad_freq_cap_on  blog-group-deadspin"><div id="splashy-ad-container-top" class="splashy-ad-container no-overflow custom-ad-sizes"><div style="display:none"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-SPLASHY_TOP ad-splashy-top GoogleActiveViewElement" data-ad-unit="SPLASHY_TOP" data-targeting="{&quot;pos&quot;:&quot;splashytop&quot;}"></div></div></div><noscript>
				<iframe
					crossOrigin="true"
					src="https://www.googletagmanager.com/ns.html?id=GTM-TH42LHK"
					height="0"
					width="0"
					style="display:none;visibility:hidden" />
			</noscript><div id="trackers"></div><div><div class="sc-101yw2y-9 cFUDQX"><div class="js_mobile-nav"></div><div class="sc-17y8tyw-0 xAnsG js_topbar"><div class="vuc0jk-0 irOnwd"><ul class="vuc0jk-1 jVZrSo"><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;avclub.com&quot;,{&quot;metric20&quot;:1}]]" href="//avclub.com">The A.V. Club</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;deadspin.com&quot;,{&quot;metric20&quot;:1}]]" href="//deadspin.com">Deadspin</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;gizmodo.com&quot;,{&quot;metric20&quot;:1}]]" href="//gizmodo.com">Gizmodo</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;jalopnik.com&quot;,{&quot;metric20&quot;:1}]]" href="//jalopnik.com">Jalopnik</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;jezebel.com&quot;,{&quot;metric20&quot;:1}]]" href="//jezebel.com">Jezebel</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;kotaku.com&quot;,{&quot;metric20&quot;:1}]]" href="//kotaku.com">Kotaku</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;lifehacker.com&quot;,{&quot;metric20&quot;:1}]]" href="//lifehacker.com">Lifehacker</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;qz.com&quot;,{&quot;metric20&quot;:1}]]" href="//qz.com">Quartz</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theroot.com&quot;,{&quot;metric20&quot;:1}]]" href="//theroot.com">The Root</a></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;thetakeout.com&quot;,{&quot;metric20&quot;:1}]]" href="//thetakeout.com">The Takeout</a></li><li class="vuc0jk-3 ixMznA"></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theonion.com&quot;,{&quot;metric20&quot;:1}]]" href="//theonion.com">The Onion</a></li><li class="vuc0jk-3 ixMznA"></li><li class="vuc0jk-2 wyrGs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theinventory.com&quot;,{&quot;metric20&quot;:1}]]" href="//theinventory.com">The Inventory</a></li></ul></div></div><span class="sc-101yw2y-7 dOTMAS overhang-wrapper"><div class="js_header"><div class="sc-1f6xobn-9 eqamLn js_header-container"><div class="sc-1f6xobn-8 kyKTts js_global-nav"><div class="sc-1f6xobn-7 gFpYje"><div class="sc-1f6xobn-0 jNeQKR"><div class="sc-1f6xobn-13 bbwfAQ"><a href="//deadspin.com" title="Deadspin" data-ga="[[&quot;Sub navigation&quot;,&quot;Logo click&quot;,&quot;Deadspin&quot;]]" class="sc-8vrmk6-0 GHWsb"><div class="sc-2d8w30-0 bGlSMu"><div class="sc-2d8w30-1 bRnfTk deadspin"><svg xmlns="http://www.w3.org/2000/svg" width="254" height="33" aria-label="Deadspin logo" viewBox="0 0 254 33"><path fill="#249D9D" fill-rule="evenodd" d="M253.73 11.23l-3.3 21.68c-.22.03-.75.09-1.46.09-1.6 0-4.53-.3-6.32-2.37-1.39-1.6-1.86-3.98-1.4-7.06 1.15-7.7 1.62-10.7 1.8-11.8l.07-.54h10.61zm-34.8-.13l-3.3 21.82c-.19.03-.7.08-1.38.08-1.62 0-4.62-.3-6.38-2.34-1.27-1.45-1.72-3.56-1.32-6.27 1.33-9.19 1.8-12.65 1.9-13.26h5.23l-.05-.03h5.3zm15.17.13l-3.16 21.72H220.9l3.13-21.72h10.06zM196.6.17c2.59 0 4.72.98 6.18 2.83a10.47 10.47 0 0 1 2.02 6.95h-28.58L177.4.17h19.2zm48.75-.04c3.12 0 5.44.91 6.9 2.71 1.85 2.3 1.85 5.42 1.68 7.08h-29.87V.13h21.29zM220.6 0l-1.47 9.79h-5.47c-2.05 0-3.35-.9-3.8-1.51-2.24-3-1.57-7.57-1.45-8.28h12.2zm-15.9 11.27c-.69 5.31-4.43 10.38-10.82 10.38h-8.81l-.06.62c-.04.46-.13 1.3-.34 2.78-1.3 7.5-9.66 7.93-11.08 7.95h-.13l2.62-21.73h28.62zM173.47 0c-.05 6.99-4.25 9.53-7.38 10.45h-22.6v-.01C143.86.62 153.5.03 154.16 0h19.3zm-9.08 11.77l.5.23c2.6 1.22 5.58 4 4.92 10.3v.13c-.97 9.94-10.2 10.56-12.25 10.57h-.08a9 9 0 0 1-.48-.01h-16.58c.05-6.93 4.7-9.44 8.04-10.34h12.12v-1.31h-10.64l-.46-.2c-2.6-1.12-5.72-3.66-5.98-9.37h20.89zM119 12l-1.66 10.88h8.5L127.49 12h10.28l-1.54 11.77c-.06.36-1.62 9.22-10.55 9.22h-19.25s-.53-.03-.87-.43c-.25-.3-.33-.72-.25-1.28L107.88 12H119zM129.31.77c3.16 0 5.5.91 6.97 2.71 1.94 2.38 1.85 5.68 1.7 7.16h-30V.77h21.33zM92.17.31c3.83 0 6.64 1.07 8.34 3.18 1.83 2.26 1.97 5.15 1.85 6.84H72.32C73.24.97 83.08.33 83.52.31h8.65zm10 11.4v.04L101.1 22.5c-.05.43-1.26 10.5-10.57 10.5-.43 0-.88-.02-1.34-.07l1.46-10.91h-20l1.59-10.24v-.17h29.96l-.02.1zm-39.34-.38h2.42c.06.03.18.1.29.26.22.32.25.87.1 1.58-.14.69-1.57 6.67-7.5 8.47H45.61v1.31H57.5l.26.1c1.5.52 2.7 1.31 3.6 2.34 1.44 1.66 2 3.92 1.66 6.71-.1.52-.95.9-2.09.9H42.3a7.32 7.32 0 0 1-4.63-2.78c-1.6-2.1-2.08-5.1-1.44-8.93.79-5.4 1.54-9.39 1.66-9.96h24.94zM80.51 23.3l-1.23 9.69H68.95l1.5-9.7h10.06zM23.87.47c3.1 0 5.42.9 6.89 2.7 2.33 2.83 1.77 7.04 1.63 7.88H2.66V.47h21.2zM68.12.14c-.04 5.7-2.91 8.46-5.4 9.8H37.9V.13h30.22zM30.75 23.69c0 .08-1.6 9.31-10.48 9.31H1.13c.01 0-.5-.03-.84-.43-.25-.3-.34-.74-.26-1.3.2-1.39 1.68-12.79 2.47-18.81h11.04L11.98 22.8h8.46l1.54-10.34H32.2l-1.45 11.23z"></path></svg></div></div></a><div class="sc-1f6xobn-15 dMGuCN">Sports News Without Fear, Favor or Compromise</div></div><div class="sc-1f6xobn-16 hCQUSp"><a href="/search" class="xpaln1-0 sc-1f6xobn-5 gjtGiE"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Search24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M15.31 1a7.69 7.69 0 1 1-5.06 13.48l-8.37 8.37a.51.51 0 1 1-.73-.72l8.37-8.38A7.69 7.69 0 0 1 15.31 1zm0 1.03a6.66 6.66 0 1 0 0 13.32 6.66 6.66 0 0 0 0-13.32z"></path></svg></span></a><a href="mailto:tips@deadspin.com" target="_self" data-ga="[[&quot;Sub navigation&quot;, &quot;Tips button click&quot;]]" class="xpaln1-0 xpaln1-1 cmUXxk js_header-shop show"><span class="iyvn34-1 wqDah"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Pencil icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M14.7 1.39l1.91 1.92c.52.51.52 1.35 0 1.87l-9.77 9.8c-.1.1-.32.2-2.02 1.02l-.03.02a567.4 567.4 0 0 1-1.92.9c-.16.08-.31.09-.76.08a17.86 17.86 0 0 1-.57-.02.5.5 0 0 1-.47-.41 4.45 4.45 0 0 1-.07-.7c0-.28.02-.5.11-.7a546.56 546.56 0 0 1 .91-1.92l.02-.03c.81-1.71.92-1.93 1.02-2.03l9.77-9.8a1.32 1.32 0 0 1 1.87 0zm-3.74 3.28l-7.2 7.22c.06-.05-.15.37-.2.48l-.62 1.28-.01.03a569.36 569.36 0 0 0-.91 1.91A2.8 2.8 0 0 0 2 16h.12c.14.01.38 0 .31.03a542.86 542.86 0 0 0 1.92-.9l.03-.02 1.27-.62c.11-.05.52-.26.47-.2l7.2-7.23-2.37-2.38zm2.58-2.58l-1.87 1.87 2.37 2.38 1.87-1.87a.33.33 0 0 0 0-.46L13.99 2.1a.32.32 0 0 0-.45 0z"></path></svg></span></span><span class="sc-1f6xobn-3 hBmvZx">Send us a tip!</span></a><a href="https://store.deadspin.com" target="_blank" data-ga="[[&quot;Sub navigation&quot;, &quot;Shop button click&quot;]]" class="xpaln1-0 xpaln1-1 cmUXxk js_header-shop show"><span class="iyvn34-1 wqDah"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Cart icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M2.5 2c.16 0 .3.07.4.2l.05.08L3.8 4h13.7a.5.5 0 0 1 .5.58l-.03.08-2 6a.5.5 0 0 1-.38.33l-.09.01H4.82l.12 1h8.56a.5.5 0 0 1 .17.03 2 2 0 1 1-1.4.97H8.73a2 2 0 1 1-3.46 0H4.5a.5.5 0 0 1-.48-.36L4 12.56l-.99-7.91L2.2 3H.5a.5.5 0 0 1-.5-.41V2.5A.5.5 0 0 1 .41 2H2.5zM14 13a1 1 0 1 0 0 2 1 1 0 0 0 0-2zm-7 0a1 1 0 1 0 0 2 1 1 0 0 0 0-2zm-2.3-3h10.44l1.66-5H4.07l.62 5z"></path></svg></span></span><span class="sc-1f6xobn-3 hBmvZx">Shop</span></a><a href="/newsletter" target="_blank" data-ga="[[&quot;Sub navigation&quot;, &quot;Subscribe button click&quot;]]" class="xpaln1-0 xpaln1-1 sc-1f6xobn-4 dNUOTA js_header-newsletter show"><span class="iyvn34-1 wqDah"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Mail icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M14.5 3A2.5 2.5 0 0 1 17 5.5v7a2.5 2.5 0 0 1-2.5 2.5h-11A2.5 2.5 0 0 1 1 12.5v-7A2.5 2.5 0 0 1 3.5 3h11zM2 5.5v7c0 .83.67 1.5 1.5 1.5h11c.83 0 1.5-.67 1.5-1.5v-7l-.03-.3-6.34 5.67a.5.5 0 0 1-.38.13.5.5 0 0 1-.38-.13l-6.7-6-.02-.02c-.1.2-.15.41-.15.64zM14.5 4h-11c-.24 0-.45.05-.65.14l6.4 5.73 6.19-5.54c-.26-.2-.58-.33-.93-.33z"></path></svg></span></span><span class="sc-1f6xobn-3 hBmvZx">Subscribe</span></a><div class="js_user-button"><div class="sc-1il3uru-2 gpLhlA"><span class="sc-1il3uru-3 eRPuSk"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="UserFilled icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M11.28 10.23c.02.02.05.03.08-.06l.21-.33.06-.09c.44-.69.64-1.06.96-1.87.66-1.7.4-3.9-.57-5.3A3.32 3.32 0 0 0 9 1c-1.47 0-2.25.45-3.03 1.57a6.04 6.04 0 0 0-.56 5.3 10.24 10.24 0 0 0 1.27 2.35c0 .03-.03.04-.16.1l-1.94.79-.06.02c-1.3.54-1.88.78-2.01.88a3 3 0 0 0-1.23 1.97A52.5 52.5 0 0 0 1 16.46c-.03.3.2.54.49.54l15-.01a.5.5 0 0 0 .5-.54 50.52 50.52 0 0 0-.27-2.43l-.09-.39a3 3 0 0 0-1.15-1.62c-.13-.1-.21-.13-2.06-.88h-.02a30.86 30.86 0 0 1-2.16-.95l.03.05z"></path></svg></span></span></div></div><a class="xpaln1-0 sc-1f6xobn-1 gYNxLk js_mobile-header-link"><span class="iyvn34-0 bYIjtl icon-hamburger"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Hamburger24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M21.5 21a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5z"></path></svg></span></a></div></div><div class="dfwuc8-2 cjLhqn"><nav class="dfwuc8-3 ebeQFC"><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;home&quot;]]" data-key="home" href="//deadspin.com/"><span>Home</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;latest&quot;]]" data-key="latest" href="//deadspin.com/latest"><span>Latest</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/baseball&quot;]]" data-index="1" href="https://deadspin.com/baseball"><span>Baseball</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/football&quot;]]" data-index="2" href="https://deadspin.com/football"><span>Football</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/basketball&quot;]]" data-index="3" href="https://deadspin.com/basketball"><span>Basketball</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/hockey&quot;]]" data-index="4" href="https://deadspin.com/hockey"><span>Hockey</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/golf&quot;]]" data-index="5" href="https://deadspin.com/golf"><span>Golf</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/soccer&quot;]]" data-index="6" href="https://deadspin.com/soccer"><span>Soccer</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/locker/the-mourning-after&quot;]]" data-index="7" href="https://deadspin.com/locker/the-mourning-after"><span>The Mourning After</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/wrestling&quot;]]" data-index="8" href="https://deadspin.com/wrestling"><span>Wrestling</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/lists&quot;]]" data-index="9" href="https://deadspin.com/lists"><span>Lists</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/tennis&quot;]]" data-index="10" href="https://deadspin.com/tennis"><span>Tennis</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/the-fights&quot;]]" data-index="11" href="https://deadspin.com/the-fights"><span>The Fights</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/olympics&quot;]]" data-index="12" href="https://deadspin.com/olympics"><span>Olympics</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/racing&quot;]]" data-index="13" href="https://deadspin.com/racing"><span>Racing</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/poker&quot;]]" data-index="14" href="https://deadspin.com/poker"><span>Poker</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/media&quot;]]" data-index="15" href="https://deadspin.com/media"><span>Media</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 ijFYhF js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click&quot;,&quot;https://deadspin.com/locker&quot;]]" data-index="16" href="https://deadspin.com/locker"><span>Locker</span></a></nav></div><div class="dfwuc8-1 lNRhM">We may earn a commission from links on this page.</div><div class="wz9htl-0 eQNljZ">Sports News Without Fear, Favor or Compromise</div></div><div class="sc-1f6xobn-2 bFfmNZ"><div class="js_sr-scores-ticker"></div></div><div class="header-bar"></div></div><div class="sc-1f6xobn-17 kPLnOz js_header-disable-overlay"></div><div class="sc-1f6xobn-21 gkUsUt js_hamburger-menu-container"></div><div class="sc-1f6xobn-18 fkpCCw js_scrollback-nav"><div class="sc-1f6xobn-8 lkemjA"><div class="sc-1f6xobn-0 ezoHdv"><div class="sc-1f6xobn-13 hZAvqW"><a href="//deadspin.com" title="Deadspin" data-ga="[[&quot;Sub navigation&quot;,&quot;Logo click - scroll back&quot;,&quot;Deadspin&quot;]]" class="sc-8vrmk6-0 GHWsb"><div class="sc-2d8w30-0 bGlSMu"><div class="sc-2d8w30-1 bRnfTk deadspin"><svg xmlns="http://www.w3.org/2000/svg" width="254" height="33" aria-label="Deadspin logo" viewBox="0 0 254 33"><path fill="#249D9D" fill-rule="evenodd" d="M253.73 11.23l-3.3 21.68c-.22.03-.75.09-1.46.09-1.6 0-4.53-.3-6.32-2.37-1.39-1.6-1.86-3.98-1.4-7.06 1.15-7.7 1.62-10.7 1.8-11.8l.07-.54h10.61zm-34.8-.13l-3.3 21.82c-.19.03-.7.08-1.38.08-1.62 0-4.62-.3-6.38-2.34-1.27-1.45-1.72-3.56-1.32-6.27 1.33-9.19 1.8-12.65 1.9-13.26h5.23l-.05-.03h5.3zm15.17.13l-3.16 21.72H220.9l3.13-21.72h10.06zM196.6.17c2.59 0 4.72.98 6.18 2.83a10.47 10.47 0 0 1 2.02 6.95h-28.58L177.4.17h19.2zm48.75-.04c3.12 0 5.44.91 6.9 2.71 1.85 2.3 1.85 5.42 1.68 7.08h-29.87V.13h21.29zM220.6 0l-1.47 9.79h-5.47c-2.05 0-3.35-.9-3.8-1.51-2.24-3-1.57-7.57-1.45-8.28h12.2zm-15.9 11.27c-.69 5.31-4.43 10.38-10.82 10.38h-8.81l-.06.62c-.04.46-.13 1.3-.34 2.78-1.3 7.5-9.66 7.93-11.08 7.95h-.13l2.62-21.73h28.62zM173.47 0c-.05 6.99-4.25 9.53-7.38 10.45h-22.6v-.01C143.86.62 153.5.03 154.16 0h19.3zm-9.08 11.77l.5.23c2.6 1.22 5.58 4 4.92 10.3v.13c-.97 9.94-10.2 10.56-12.25 10.57h-.08a9 9 0 0 1-.48-.01h-16.58c.05-6.93 4.7-9.44 8.04-10.34h12.12v-1.31h-10.64l-.46-.2c-2.6-1.12-5.72-3.66-5.98-9.37h20.89zM119 12l-1.66 10.88h8.5L127.49 12h10.28l-1.54 11.77c-.06.36-1.62 9.22-10.55 9.22h-19.25s-.53-.03-.87-.43c-.25-.3-.33-.72-.25-1.28L107.88 12H119zM129.31.77c3.16 0 5.5.91 6.97 2.71 1.94 2.38 1.85 5.68 1.7 7.16h-30V.77h21.33zM92.17.31c3.83 0 6.64 1.07 8.34 3.18 1.83 2.26 1.97 5.15 1.85 6.84H72.32C73.24.97 83.08.33 83.52.31h8.65zm10 11.4v.04L101.1 22.5c-.05.43-1.26 10.5-10.57 10.5-.43 0-.88-.02-1.34-.07l1.46-10.91h-20l1.59-10.24v-.17h29.96l-.02.1zm-39.34-.38h2.42c.06.03.18.1.29.26.22.32.25.87.1 1.58-.14.69-1.57 6.67-7.5 8.47H45.61v1.31H57.5l.26.1c1.5.52 2.7 1.31 3.6 2.34 1.44 1.66 2 3.92 1.66 6.71-.1.52-.95.9-2.09.9H42.3a7.32 7.32 0 0 1-4.63-2.78c-1.6-2.1-2.08-5.1-1.44-8.93.79-5.4 1.54-9.39 1.66-9.96h24.94zM80.51 23.3l-1.23 9.69H68.95l1.5-9.7h10.06zM23.87.47c3.1 0 5.42.9 6.89 2.7 2.33 2.83 1.77 7.04 1.63 7.88H2.66V.47h21.2zM68.12.14c-.04 5.7-2.91 8.46-5.4 9.8H37.9V.13h30.22zM30.75 23.69c0 .08-1.6 9.31-10.48 9.31H1.13c.01 0-.5-.03-.84-.43-.25-.3-.34-.74-.26-1.3.2-1.39 1.68-12.79 2.47-18.81h11.04L11.98 22.8h8.46l1.54-10.34H32.2l-1.45 11.23z"></path></svg></div></div></a></div><div class="dfwuc8-2 dWavFu"><nav class="dfwuc8-3 gRDQUf"><div class="dfwuc8-4 gHzeLS"></div><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;home&quot;]]" data-key="home" href="//deadspin.com/"><span>Home</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;latest&quot;]]" data-key="latest" href="//deadspin.com/latest"><span>Latest</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/baseball&quot;]]" data-index="1" href="https://deadspin.com/baseball"><span>Baseball</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/football&quot;]]" data-index="2" href="https://deadspin.com/football"><span>Football</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/basketball&quot;]]" data-index="3" href="https://deadspin.com/basketball"><span>Basketball</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/hockey&quot;]]" data-index="4" href="https://deadspin.com/hockey"><span>Hockey</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/golf&quot;]]" data-index="5" href="https://deadspin.com/golf"><span>Golf</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/soccer&quot;]]" data-index="6" href="https://deadspin.com/soccer"><span>Soccer</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/locker/the-mourning-after&quot;]]" data-index="7" href="https://deadspin.com/locker/the-mourning-after"><span>The Mourning After</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/wrestling&quot;]]" data-index="8" href="https://deadspin.com/wrestling"><span>Wrestling</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/lists&quot;]]" data-index="9" href="https://deadspin.com/lists"><span>Lists</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/tennis&quot;]]" data-index="10" href="https://deadspin.com/tennis"><span>Tennis</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/the-fights&quot;]]" data-index="11" href="https://deadspin.com/the-fights"><span>The Fights</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/olympics&quot;]]" data-index="12" href="https://deadspin.com/olympics"><span>Olympics</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/racing&quot;]]" data-index="13" href="https://deadspin.com/racing"><span>Racing</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/poker&quot;]]" data-index="14" href="https://deadspin.com/poker"><span>Poker</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/media&quot;]]" data-index="15" href="https://deadspin.com/media"><span>Media</span></a><a class="sc-1out364-0 hMndXN dfwuc8-0 kOwiGs js_link" data-ga="[[&quot;Sub navigation&quot;,&quot;Vertical/Tag click - scroll back&quot;,&quot;https://deadspin.com/locker&quot;]]" data-index="16" href="https://deadspin.com/locker"><span>Locker</span></a></nav></div><div class="sc-1f6xobn-16 elSSjd"><a href="/search" class="xpaln1-0 sc-1f6xobn-5 gjtGiE"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Search24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M15.31 1a7.69 7.69 0 1 1-5.06 13.48l-8.37 8.37a.51.51 0 1 1-.73-.72l8.37-8.38A7.69 7.69 0 0 1 15.31 1zm0 1.03a6.66 6.66 0 1 0 0 13.32 6.66 6.66 0 0 0 0-13.32z"></path></svg></span></a><div class="js_user-button"><div class="sc-1il3uru-2 gpLhlA"><span class="sc-1il3uru-3 eRPuSk"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="UserFilled icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M11.28 10.23c.02.02.05.03.08-.06l.21-.33.06-.09c.44-.69.64-1.06.96-1.87.66-1.7.4-3.9-.57-5.3A3.32 3.32 0 0 0 9 1c-1.47 0-2.25.45-3.03 1.57a6.04 6.04 0 0 0-.56 5.3 10.24 10.24 0 0 0 1.27 2.35c0 .03-.03.04-.16.1l-1.94.79-.06.02c-1.3.54-1.88.78-2.01.88a3 3 0 0 0-1.23 1.97A52.5 52.5 0 0 0 1 16.46c-.03.3.2.54.49.54l15-.01a.5.5 0 0 0 .5-.54 50.52 50.52 0 0 0-.27-2.43l-.09-.39a3 3 0 0 0-1.15-1.62c-.13-.1-.21-.13-2.06-.88h-.02a30.86 30.86 0 0 1-2.16-.95l.03.05z"></path></svg></span></span></div></div><a class="xpaln1-0 sc-1f6xobn-1 gYNxLk js_mobile-header-link"><span class="iyvn34-0 bYIjtl icon-hamburger"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Hamburger24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M21.5 21a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5z"></path></svg></span></a></div></div></div></div></div></div><div class="sc-101yw2y-0 FrOFK initWrappers"><span class="sc-101yw2y-2 iZCRsA js_custom-header-toolbar-container"></span><div class="sc-101yw2y-1 eTAcyr js_curation-toolbar-container"></div></div><div class="sc-101yw2y-1 eTAcyr js_curation-editor-container"></div></span><div class="sc-1op1dd6-0 cLjaxQ js_sticky-top-ad"><div class="sc-1jotqfp-0 sc-1jotqfp-2 ja-dtMJ js_desktop-horizontal-ad"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-TOP_BANNER ad-top-banner collapsed-ad" data-ad-unit="TOP_BANNER" data-targeting="{&quot;pos&quot;:&quot;top&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a5c7d-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-top-banner collapsed-ad"></span></div></div></div><div class="sc-157agsr-1 sc-157agsr-2 iHvAmE"><div class="js_privacy_policy"></div><div class="sc-9tztzq-2 fkvsnH"><div class="sc-235a11-0 eTaWyD"><a class="sc-1out364-0 hMndXN fek4t4-0 ciBiKu js_link" data-ga="[[&quot;Permalink meta&quot;,&quot;Channel click&quot;,&quot;/basketball/nba&quot;]]" href="/basketball/nba"><div class="fek4t4-1 iPMcTh">NBA</div></a></div><header class="sc-1efpnfq-1 hQgdUv"><h1 class="sc-1efpnfq-0 joZwQS">Lillard nominating himself as the second-best shooter in NBA history was the ultimate heat check</h1></header><h2 class="sc-1xcxnn7-0 dcCsdH js_regular-subhead">Dame is really good, but come on, is he that good?</h2></div></div><div class="sc-157agsr-0 knYNlh"><main class="sc-11qwj9y-1 fOXYxq"><div class="sc-11qwj9y-0 TCDpD"><script type="application/ld+json">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</script><div class="js_starterpost"><div class="sc-1fofo4n-0 cdfDtI"><div class="sc-83o472-3 fGAmnx"><div class="sc-83o472-0 eNqIWy"><div class="sc-1jc3ukb-0 eJFjvj"><div class="sc-1jc3ukb-3 bPVaPw"><span>By</span><div class="sc-1mep9y1-0 sc-1ixdk2y-0 kiViVs"><a class="sc-1out364-0 hMndXN js_link" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/djdunson&quot;]]" href="/author/djdunson">DJ Dunson</a></div></div></div><div class="sc-1jc3ukb-2 fASvtw"><div class="sc-1jc3ukb-1 eYTvqt"></div><time class="uhd9ir-0 iziAPV" dateTime="2022-12-20T16:06:00-05:00"><span class="uhd9ir-2 fWvkXn">Published</span>2 hours ago</time></div><div class="sc-15g8630-0 bBBgzc"><div class="sc-15g8630-1 bdjtuA"><div class="sc-1jc3ukb-1 eYTvqt"></div><div class="js_alerts_modal"><a class="sc-1out364-0 hMndXN js_link">Alerts</a></div></div></div><div class="sc-83o472-12 hQFeJN"><div class="post-tools-wrapper" data-state="{&quot;type&quot;:&quot;permalink&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;authorIds&quot;:[&quot;5876237249239991117&quot;],&quot;sharedToBlogId&quot;:null,&quot;status&quot;:&quot;PUBLISHED&quot;,&quot;postPermalink&quot;:&quot;https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&quot;,&quot;wordCount&quot;:952,&quot;isFeatured&quot;:false,&quot;isVideo&quot;:false,&quot;isEmbiggened&quot;:false,&quot;parentId&quot;:null,&quot;parentAuthorId&quot;:null,&quot;defaultBlogId&quot;:&quot;11&quot;,&quot;index&quot;:0,&quot;pageType&quot;:&quot;permalink&quot;,&quot;isDismissed&quot;:false,&quot;isBlocked&quot;:false}" data-post-id="1849916545" data-post-permalink="https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545"><div class="sc-1vjnuu8-0 ieQQVs"><div class="sc-12i6d45-0 jmlRJq"><div class="sc-12i6d45-1 dYVcML"></div></div></div></div></div></div><div class="sc-83o472-2 CzHho">We may earn a commission from links on this page.</div><div class="sc-83o472-5 fcsoed share-tools-buttons-top"></div></div></div><div class="xs32fe-0 iOFxrO js_post-content"><figure class="sc-1eow4w5-1 eLNveM align--bleed js_lazy-image js_marquee-assetfigure" data-id="5093af871630a224159981c51d6d1d7f" data-recommend-id="image://5093af871630a224159981c51d6d1d7f" data-format="jpg" data-width="3660" data-height="2058" data-lightbox="true" data-recommended="false" data-hide="false" contenteditable="false" draggable="false"><div class="sc-1eow4w5-2 loxZOX has-data img-wrapper" contenteditable="false" style="max-width:3660px" data-link-reference="" data-link-target="" data-syndicationrights="true" data-imagerights="getty" data-hide="false" data-hidecredit="false"><span class="sc-1eow4w5-0 dnhHtZ js_lightbox-wrapper"><div class="sc-1m41dwj-0 bByIIk magnifier js_lightbox lightbox hide"><span class="iyvn34-0 bYIjtl"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="ZoomIn icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M10.5 1a6.5 6.5 0 1 1-4.23 11.44l-4.42 4.41a.5.5 0 0 1-.7-.7l4.41-4.42A6.5 6.5 0 0 1 10.5 1zm0 1a5.5 5.5 0 1 0 0 11 5.5 5.5 0 0 0 0-11zm0 2c.28 0 .5.22.5.5V7h2.5a.5.5 0 0 1 .5.41v.09a.5.5 0 0 1-.5.5H11v2.5a.5.5 0 0 1-.41.5h-.09a.5.5 0 0 1-.5-.5V8H7.5a.5.5 0 0 1-.5-.41V7.5c0-.28.22-.5.5-.5H10V4.5a.5.5 0 0 1 .41-.5z"></path></svg></span></div><div style="padding-bottom:56.2%" class="sc-1eow4w5-3 lktKQM image-hydration-wrapper"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" alt="Image for article titled Lillard nominating himself as the second-best shooter in NBA history was the ultimate heat check" data-srcset="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/5093af871630a224159981c51d6d1d7f.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_140/5093af871630a224159981c51d6d1d7f.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_265/5093af871630a224159981c51d6d1d7f.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_340/5093af871630a224159981c51d6d1d7f.jpg 340w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_490/5093af871630a224159981c51d6d1d7f.jpg 490w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_645/5093af871630a224159981c51d6d1d7f.jpg 645w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_740/5093af871630a224159981c51d6d1d7f.jpg 740w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_965/5093af871630a224159981c51d6d1d7f.jpg 965w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1165/5093af871630a224159981c51d6d1d7f.jpg 1165w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1315/5093af871630a224159981c51d6d1d7f.jpg 1315w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1465/5093af871630a224159981c51d6d1d7f.jpg 1465w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1600/5093af871630a224159981c51d6d1d7f.jpg 1600w" sizes="
				(max-width: 25em) calc(100vw - 32px),
				(max-width: 37.31em) calc(100vw - 32px),
				(min-width: 37.37em) and (max-width: 49.94em) calc(100vw - 32px),
				(min-width: 50em) and (max-width: 63.69em) 800px,
				(min-width: 63.75em) and (max-width: 85.19em) calc(66.5vw - 32px),
				800px
			" draggable="auto" data-chomp-id="5093af871630a224159981c51d6d1d7f" data-format="jpg" data-alt="Image for article titled Lillard nominating himself as the second-best shooter in NBA history was the ultimate heat check" data-anim-src=""/></div></div></span><div class="sc-1eow4w5-4 bNSWel image-meta"><figcaption class="sc-7s1ndr-0 ikKPtM no-caption">Image<!-- -->: <!-- -->Getty Images</figcaption></div></div><span data-id="5093af871630a224159981c51d6d1d7f" data-recommend-id="image://5093af871630a224159981c51d6d1d7f" data-format="jpg" data-width="3660" data-height="2058" data-lightbox="true" data-recommended="false" data-hide="false" class="js_recommend"></span></figure><p class="sc-77igqf-0 bOfvBY">Damian Lillard’s Trail Blazers career has reached an inflection point where his legacy is solidifying. We feel it, fans feel it, the record books are feeling it and Dame is sensing it. On Monday night, Lillard eclipsed Clyde Drexler to become the franchise’s all-time leading scorer. Lillard’s career has been an exhilarating ride, but his opportunity to remain significant beyond this generation is slipping away. For years in the mid-2010s, a contingent of NBA insiders or fans tried to argue Lillard was on Steph Curry’s plane of existence as a shooter. </p><div class="bxm4mm-2 hKBnez"><div class="bxm4mm-1 goloRq instream-native-video instream-permalink instream-native-video--mobile"><div class="sc-1h0epat-0 hykIxg"><div class="sc-1h0epat-1 gRjwiT"><div class="sc-235a11-0 bDMZeP">Watch</div></div><div class="sc-1wkneyl-0 hxLRyg video-html5-playlist" data-playlist="191117,191024,191118" data-current="191117"><div class="video-html5-loaded"><div class="video-html5-player"><div class="lhhce6-0 bVyOPq video-html5 autoplay muted mobile" data-video-id="191117" data-monetizable="true" data-position="sidebar" data-video-title="Who will be the NBA Finals MVP? | The Weigh In" data-video-blog-id="11" data-video-network="deadspin" data-video-duration="127"><video disablepictureinpicture="" muted="" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_362,pg_1,q_60,w_645/50746e996a87656cb8209836cc21d4ec.jpg" width="100%" height="100%" crossorigin="anonymous" preload="none" style="max-height:none"><source data-src="https://vid.kinja.com/prod/191117/191117_240p.mp4" label="240p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_480p.mp4" label="480p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_720p.mp4" label="720p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_1080p.mp4" label="1080p" type="video/mp4"/><track kind="captions" label="English" src="https://kinja.com/api/videoupload/caption/17184.vtt" srclang="en"/></video><div class="lhhce6-1 bmmbnr advertisement"></div><div class="ag987e-0 ixVloN btn btn-play" role="button">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div><div class="sc-1yhvqfu-2 eQhEAz video-controls"><div class="sc-1yhvqfu-0 jpPsoD play-pause "><svg class="play" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v6l6-3-6-3z" transform="translate(1 1)"></path></svg><svg class="pause" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v6h2v-6h-2zm4 0v6h2v-6h-2z" transform="translate(1 1)"></path></svg></div><div class="sc-1yhvqfu-0 jpPsoD mute-volume"><div class="sc-1yhvqfu-0 jpPsoD mute-unmute muted"><svg class="mute" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M3.34 0l-1.34 2h-2v4h2l1.34 2h.66v-8h-.66zm1.66 1v1c.17 0 .34.02.5.06.86.22 1.5 1 1.5 1.94s-.63 1.72-1.5 1.94c-.16.04-.33.06-.5.06v1c.25 0 .48-.04.72-.09h.03c1.3-.33 2.25-1.51 2.25-2.91 0-1.4-.95-2.58-2.25-2.91-.23-.06-.49-.09-.75-.09zm0 2v2c.09 0 .18-.01.25-.03.43-.11.75-.51.75-.97 0-.46-.31-.86-.75-.97-.08-.02-.17-.03-.25-.03z"></path></svg><svg class="unmute" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M3.34 0l-1.34 2h-2v4h2l1.34 2h.66v-8h-.66z" transform="translate(2)"></path></svg></div><div class="sc-1yhvqfu-1 ZmLTq volume"><progress min="0" max="100" value="80"></progress></div></div><div class="sc-1yhvqfu-1 ZmLTq progress"><progress min="0" max="127" value="0"></progress></div><div class="sc-1yhvqfu-0 jpPsoD duration"></div><div class="sc-1yhvqfu-0 jpPsoD fullscreen"><svg xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v4l1.5-1.5 1.5 1.5 1-1-1.5-1.5 1.5-1.5h-4zm5 4l-1 1 1.5 1.5-1.5 1.5h4v-4l-1.5 1.5-1.5-1.5z"></path></svg></div><div class="sc-1yhvqfu-0 jpPsoD closed-captions"><button class="cc" type="button">CC</button><ul><li class="selected" data-label="">Off</li><li class="" data-label="English">English</li></ul></div></div></div></div><div class="video-html5-info"><div><div class="sc-1ltrdwy-0 dYjpmh"><a class="sc-1out364-0 hMndXN sc-1ltrdwy-1 kUjuXJ js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;Title click&quot;,&quot;kinjavideo-191117&quot;]]" href="https://deadspin.com/who-will-be-the-nba-finals-mvp-the-weigh-in-1849066153" data-key="permalink"><span data-key="title" class="sc-1ltrdwy-2 clJTGM">Who will be the NBA Finals MVP? | The Weigh In</span></a></div></div></div></div><div class="video-html5-thumbs"><div class="sc-14ojfpu-6 ekJydD"><div data-key="191024" class="sc-14ojfpu-5 jdlHci"><a class="sc-1out364-0 hMndXN sc-14ojfpu-4 hRbPxS js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;click - position 1 of 2&quot;,&quot;kinjavideo-191024&quot;]]" href="https://deadspin.com/a-march-madness-style-nba-playoff-would-change-history-1849023676"><div class="sc-1v01hk4-1 eDBID"><div class="sc-1v01hk4-0 itJsme"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/4911cffa4f4d86e37f495e004adac8f6.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_78,pg_1,q_60,w_140/4911cffa4f4d86e37f495e004adac8f6.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_149,pg_1,q_60,w_265/4911cffa4f4d86e37f495e004adac8f6.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_191,pg_1,q_60,w_340/4911cffa4f4d86e37f495e004adac8f6.jpg 340w" alt="" draggable="auto" data-chomp-id="4911cffa4f4d86e37f495e004adac8f6" data-format="jpg" data-alt="" data-anim-src=""/></div><div class="sc-4cqztc-0 kVwmYN">01:49</div></div><div class="sc-1v01hk4-2 evhnTd"><div class="sc-1v01hk4-3 jolTTN">Now playing</div></div><div class="ag987e-0 sc-1v01hk4-4 fPBAtf">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div></div><div class="sc-14ojfpu-2 innqYa"><div class="sc-14ojfpu-0 hrWYNy">A March Madness-style NBA playoff would change history</div><div class="sc-14ojfpu-1 eqLCCh">June 6, 2022</div></div></a></div><div data-key="191118" class="sc-14ojfpu-5 jdlHci"><a class="sc-1out364-0 hMndXN sc-14ojfpu-4 hRbPxS js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;click - position 2 of 2&quot;,&quot;kinjavideo-191118&quot;]]" href="https://deadspin.com/top-5-single-digit-scorers-in-nba-history-1849066959"><div class="sc-1v01hk4-1 eDBID"><div class="sc-1v01hk4-0 itJsme"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/17d7f6a2c61eb57703e6c0c308c621f8.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_78,pg_1,q_60,w_140/17d7f6a2c61eb57703e6c0c308c621f8.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_149,pg_1,q_60,w_265/17d7f6a2c61eb57703e6c0c308c621f8.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_191,pg_1,q_60,w_340/17d7f6a2c61eb57703e6c0c308c621f8.jpg 340w" alt="" draggable="auto" data-chomp-id="17d7f6a2c61eb57703e6c0c308c621f8" data-format="jpg" data-alt="" data-anim-src=""/></div><div class="sc-4cqztc-0 kVwmYN">02:01</div></div><div class="sc-1v01hk4-2 evhnTd"><div class="sc-1v01hk4-3 jolTTN">Now playing</div></div><div class="ag987e-0 sc-1v01hk4-4 fPBAtf">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div></div><div class="sc-14ojfpu-2 innqYa"><div class="sc-14ojfpu-0 hrWYNy">Top 5 single digit scorers in NBA history</div><div class="sc-14ojfpu-1 eqLCCh">June 15, 2022</div></div></a></div></div></div></div></div></div></div><p class="sc-77igqf-0 bOfvBY">Over time the contrarians have faded away. A few doofuses exist, but recognizing Curry as the Patron Saint of Shotmakers has become basketball orthodoxy. However, Lillard has clearly felt overshadowed by Curry’s accomplishments. Two years ago, he remarked on <span><a class="sc-1out364-0 hMndXN sc-145m8ut-0 kGbjEv js_link" data-ga="[[&quot;Embedded Url&quot;,&quot;External link&quot;,&quot;https://larrybrownsports.com/basketball/damian-lillard-controversial-comments-stephen-curry-warriors-blazers/571072&quot;,{&quot;metric25&quot;:1}]]" href="https://larrybrownsports.com/basketball/damian-lillard-controversial-comments-stephen-curry-warriors-blazers/571072" target="_blank" rel="noopener noreferrer">Curry struggling </a></span>without his All-Star castmates and ultimately had to eat his words.<br/></p><div class="sc-1xxadal-0 jICWEe js_related-stories-inset"></div><p class="sc-77igqf-0 bOfvBY">His most recent blasphemy might be worse. In his postgame remarks on Monday, Lillard explained where he believes he should rank among the preeminent shooters in league history.<br/></p><blockquote data-type="BlockQuote" class="sc-8hxd3p-0 kDHBHL"><p class="sc-77igqf-0 bOfvBY">“I always see stuff on social media where they talk about the greatest shooters of all time and they always act like it’s just crazy for people to mention me,” Lillard said. “I think for how many threes I’ve made, for how consistent I make them, the level of difficulty that I shoot threes with over years and years and years, I just think it’s kind of crazy people don’t mention me in those discussions.”</p></blockquote><div class="qqiwox-0 hgekAP js_rev-content-placeholder"><div id="rc-widget-fcd74d" data-disable-demand="true" data-rc-widget="true" data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="274362"></div></div><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">Lillard continued with his explanation, but it didn’t get better.<br/></p><blockquote data-type="BlockQuote" class="sc-8hxd3p-0 kDHBHL"><p class="sc-77igqf-0 bOfvBY">“Obviously I think Steph is the greatest ever, but I think after him, I don’t see why I’m not clear-cut in that discussion, not just by makes, but how I shoot it, how I make tough ones all the time, how easy I shoot the ball,” Lillard added. “I’m looking forward to keep climbing that list so once I get up there in that top two, top three, I’m curious to see what people will say about me as a shooter at that point.”</p></blockquote><div class="bxm4mm-15 BiRlJ"><div class="sc-1atgi65-0 sc-19jt9hn-12 iunChe js_commerce-inset-permalink" data-inset-url="https://www.amazon.com/Tushy-Classic-Bidet-Toilet-Attachment/dp/B08VS11Z1N?asc_campaign=InlineMobile&amp;asc_refurl=https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&amp;asc_source=&amp;imprToken=3cc297f8-1ad4-aa32-fdd&amp;ots=1&amp;slotNum=1&amp;tag=kinjadeadspinpromo-20" data-inset-category="CommerceInsetMobile"><a class="sc-1out364-0 hMndXN sc-1atgi65-4 sc-19jt9hn-1 iFeFqD js_link" data-ga="[[&quot;CommerceInsetMobile&quot;,&quot;Click&quot;,&quot;https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&quot;],[&quot;ns:unique&quot;,&quot;CommerceInsetMobile&quot;,&quot;Click&quot;,&quot;https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&quot;],[&quot;Embedded Url&quot;,&quot;CommerceInsetMobile&quot;,&quot;https://www.amazon.com/Tushy-Classic-Bidet-Toilet-Attachment/dp/B08VS11Z1N?asc_campaign=InlineMobile&amp;asc_refurl=https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&amp;asc_source=&amp;imprToken=3cc297f8-1ad4-aa32-fdd&amp;ots=1&amp;slotNum=1&amp;tag=kinjadeadspinpromo-20&quot;,{&quot;metric25&quot;:1}]]" href="https://www.amazon.com/Tushy-Classic-Bidet-Toilet-Attachment/dp/B08VS11Z1N?asc_campaign=InlineMobile&amp;asc_refurl=https://deadspin.com/lillard-nominating-himself-as-the-second-best-shooter-i-1849916545&amp;asc_source=&amp;imprToken=3cc297f8-1ad4-aa32-fdd&amp;ots=1&amp;slotNum=1&amp;tag=kinjadeadspinpromo-20" data-linktype="[t|mod-all" target="_blank" rel="nofollow"><div class="sc-19jt9hn-0 eGPKIe"><div class="sc-19jt9hn-7 NsWwt js_lazy-image top-image"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_140/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_265/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_340/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 340w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_490/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 490w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_645/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 645w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_740/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 740w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_965/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 965w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1165/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 1165w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1315/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 1315w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1465/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 1465w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1600/fcff13e1e14f7b3a2a7818103a83e3f6.jpg 1600w" sizes="265px" alt="Top Image" draggable="auto" data-chomp-id="fcff13e1e14f7b3a2a7818103a83e3f6" data-format="png" data-alt="Top Image" data-anim-src=""/></div></div><div class="sc-19jt9hn-8 copXfq"><div class="sc-19jt9hn-7 NsWwt js_lazy-image tout-image"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/19a9a3f85ee515bc0822e28bde781e1f.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_140/19a9a3f85ee515bc0822e28bde781e1f.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_265/19a9a3f85ee515bc0822e28bde781e1f.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_340/19a9a3f85ee515bc0822e28bde781e1f.jpg 340w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_490/19a9a3f85ee515bc0822e28bde781e1f.jpg 490w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_645/19a9a3f85ee515bc0822e28bde781e1f.jpg 645w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_740/19a9a3f85ee515bc0822e28bde781e1f.jpg 740w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_965/19a9a3f85ee515bc0822e28bde781e1f.jpg 965w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1165/19a9a3f85ee515bc0822e28bde781e1f.jpg 1165w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1315/19a9a3f85ee515bc0822e28bde781e1f.jpg 1315w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1465/19a9a3f85ee515bc0822e28bde781e1f.jpg 1465w, https://i.kinja-img.com/gawker-media/image/upload/c_fit,f_auto,g_center,pg_1,q_60,w_1600/19a9a3f85ee515bc0822e28bde781e1f.jpg 1600w" sizes="140px" alt="Tout Image" draggable="auto" data-chomp-id="19a9a3f85ee515bc0822e28bde781e1f" data-format="png" data-alt="Tout Image" data-anim-src=""/></div></div><div class="sc-19jt9hn-10 hJkkEL">20% off</div></div><div><div class="sc-19jt9hn-7 NsWwt js_lazy-image product-image"><div><img src="https://i.kinja-img.com/gawker-media/image/upload/c_fill,fl_progressive,g_center,h_264,q_80,w_470/63fd5c9752f9ee8efe614cb962f5a4b2.jpg" sizes="490px" width="400" height="225" alt="Tushy Classic 3.0 Bidet Toilet Seat Attachment"/></div></div><div class="sc-19jt9hn-11 ketjry"><div class="sc-19jt9hn-6 iezLmQ"><h3 class="sc-19jt9hn-5 kFTOpk">Tushy Classic 3.0 Bidet Toilet Seat Attachment</h3></div><div class="sc-19jt9hn-2 brgtVF content-container"><p class="sc-1atgi65-13 iFlqWg"><strong>Switch to a bidet today!</strong><br/><span>Wiping over and over with paper is no way to get yourself clean.</span></p></div><div class="sc-19jt9hn-2 brgtVF tout-container"><div class="sc-19jt9hn-9 gmERNP"></div></div></div></div><div class="sc-19jt9hn-3 GLsvx"><div class="sc-19jt9hn-4 bbZjXK"><button class="sc-1rvv6e6-7 iEXGwg sc-1atgi65-11 ighzBW"><label class="sc-1rvv6e6-1 jXcwUR">Buy for <strong>$87</strong> at Amazon</label></button></div></div></div></a></div><div class="bxm4mm-6 dIYVrz"><div class="bxm4mm-0 cULvCC"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-OUTSTREAM_PASSBACK ad-commerce commerce-leg-wrapper" data-dfp-site-code="gm.deadspin" data-ad-unit="OUTSTREAM_PASSBACK" data-targeting="{&quot;pos&quot;:&quot;outstream_passback&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div></div></div><p class="sc-77igqf-0 bOfvBY">When Lillard thrusts himself into the top two or three all-time<!-- --> he’s probably referring to the career 3-pointers made list, but booiiiiiiii… Sometimes that supreme confidence that enables him to take 30-footers with no regard, goes a little too far. Lillard is great, but he wouldn’t even reach the NBA Shooter’s Mt. Rushmore.<br/></p><p class="sc-77igqf-0 bOfvBY">Even if you stick to the modern-day<!-- --> NBA, Kevin Durant is the purest elite shooting alternative to Curry. His career three-point shooting percentage of 38 percent matches Lillard’s except he’s also one of the preeminent mid<!-- -->range<!-- --> shooters of the modern era and he gets it done in the postseason too. Durant’s lanky arms stretch longer than most peninsulas, making his shot impossible to block when he rises and extends. There’s a reason his form is the standard by which Victor Wambanyama’s perimeter shooting upside is measured.<br/></p><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">Durant gets overlooked because he’s bigger, not as shifty and he prefers to take the occasional midrange<!-- --> jumper than launch drone missiles from the logo. Due to his immense size and length, Durant isn’t as limited on drives to the basket, therefore his scoring profile isn’t as reliant on the arc. But when he does, he’s a force to be reckoned with.<br/></p><p class="sc-77igqf-0 bOfvBY">To Lillard’s credit, he has established himself as one of the <span><a class="sc-1out364-0 hMndXN sc-145m8ut-0 kGbjEv js_link" data-ga="[[&quot;Embedded Url&quot;,&quot;External link&quot;,&quot;https://twitter.com/kirkgoldsberry/status/1452338422568390656?s=20&amp;t=iwD_PVmjlHkaSJ6-_5bSDg&quot;,{&quot;metric25&quot;:1}]]" href="https://twitter.com/kirkgoldsberry/status/1452338422568390656?s=20&amp;t=iwD_PVmjlHkaSJ6-_5bSDg" target="_blank" rel="noopener noreferrer">two most prolific shooters</a></span> beyond 30 feet<!-- --> in NBA history. That’s partially because until recently, taking “<span><a class="sc-1out364-0 hMndXN sc-145m8ut-0 kGbjEv js_link" data-ga="[[&quot;Embedded Url&quot;,&quot;External link&quot;,&quot;https://www.youtube.com/watch?v=IH7Jfe-40Qc&quot;,{&quot;metric25&quot;:1}]]" href="https://www.youtube.com/watch?v=IH7Jfe-40Qc" target="_blank" rel="noopener noreferrer">bad shots</a></span>” from that distance was frowned upon. Between 2015-16 and 2021, <span><a class="sc-1out364-0 hMndXN sc-145m8ut-0 kGbjEv js_link" data-ga="[[&quot;Embedded Url&quot;,&quot;External link&quot;,&quot;https://twitter.com/kirkgoldsberry/status/1452338422568390656?s=20&amp;t=iwD_PVmjlHkaSJ6-_5bSDg&quot;,{&quot;metric25&quot;:1}]]" href="https://twitter.com/kirkgoldsberry/status/1452338422568390656?s=20&amp;t=iwD_PVmjlHkaSJ6-_5bSDg" target="_blank" rel="noopener noreferrer">Lillard’s efficiency was more <!-- -->comparable to Trae Young’s volume shooting </a></span>than<!-- --> Curry’s wet work. <!-- -->The disparity between Lillard and Curry from 30 feet or more is so wide that during that span, Curry was more accurate on deep threes than Lillard from 24 feet<!-- --> out.<br/></p><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">Lillard is a pioneer of the intercontinental 3-pointer, but placing him as Curry’s salutatorian is an Everest-level climb. Lillard’s belief in himself is both overconfidence and a classic example of recency bias run amok. Right now, he’s approximately 1,000 behind Ray Allen and trails Reggie Miller by 1,300 triples. Larry Bird wasn’t fortunate enough to participate in the 3-point era, yet his shooting prowess is almost mythical.<br/></p><p class="sc-77igqf-0 bOfvBY">Miller and Allen were imitable shooters from the 3-point arc’s Mesozoic era. Allen in particular was a master of long-distance strikes. His form was frozen in amber for nearly two decades. His consistency was unmatched and in Allen’s prime, he was an elite three-level scorer who could finish above the rim.<br/></p><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">But all of this is moot without Lillard acknowledging the only other player whose individual accomplishments match Curry’s and had the cultural chokehold on the greatest shooter alive belt until Curry’s ascension. Larry Bird was an absolute sniper, MVP,<!-- --> and three-time champion whose arsenal included long-range leaners, fadeaways,<!-- --> and the occasional game of crunchtime HORSE.<br/></p><p class="sc-77igqf-0 bOfvBY">Six times, Bird shot over 40 percent from distance, but rarely took more than one triple a night during his nascent years in the league which coincided <!-- -->with the advent of the 3-point line and established a monopoly over the first trio of 3-point c<!-- -->ontests until he retired from the event.<br/></p><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">In an era where distance shooting was an afterthought, Bird was still able to join the exclusive<br/></p><p class="sc-77igqf-0 bOfvBY">50-40-90 club twice while Lillard has only finished one season with a 3-point shooting percentage over .400. Bird deserves some respect on his name. But so do Kyrie Irving, who has stormed the 50-40-90 club, and Irving’s former coach, Steve Nash, who <!-- -->joined the club four times. </p><div id="" class="bxm4mm-6 dIYVrz js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad"><div class="bxm4mm-3 bxm4mm-4 gQxdfk"></div><div class="bxm4mm-8 dpxQKd ad-unit ad-mobile"><div class="bxm4mm-9 gWoRrF">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-dfp-site-code="gm.deadspin" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;,&quot;postId&quot;:&quot;1849916545&quot;,&quot;blogName&quot;:&quot;deadspin&quot;,&quot;tags&quot;:&quot;nba,nationalbasketballassociation,young,allens,clydedrexler,kyrieirving,reggiemiller,stevenash,larrybird,stephcurry,thenba,sportspeople,damianlillard,victorwambanyama,wardell,stephencurry,kevindurant,rayallen&quot;,&quot;channel&quot;:&quot;basketball&quot;,&quot;section&quot;:&quot;nba&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-3 bxm4mm-5 cbuuRJ"></div></div><p class="sc-77igqf-0 bOfvBY">Lillard is an exceptional long-distance assassin, but putting him up for consideration as the best shooter of all time<!-- --> not named Wardell is a high bar. That’s a bustling list leaving Lillard lost in the crowd.<!-- --> <br/></p><div class="wdg44t-8 dLnlzm js_newsletter-form-inline"></div></div><div class="js_liveblog-controls"></div><div class="js_qanda-controls"></div><div class="js_ymal-below-post"></div><div class="js_more-below-post"></div><div class="sc-73739c-2 gaZVrz"><div class="sc-38bsvh-0 fncPRR"><a class="sc-1out364-0 hMndXN sc-15604uf-0 lgsULC js_link" data-ga="[[&quot;Permalink meta&quot;,&quot;Channel click&quot;,&quot;https://deadspin.com/basketball&quot;]]" href="https://deadspin.com/basketball"><span class="ov8naf-0 jaLBMG">Basketball</span></a><span class="iyvn34-0 bYIjtl sc-15604uf-1 gWTDFv"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="DoubleChevronRight icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M3.13 3.16a.5.5 0 0 1 .7-.03l6 5.5.07.07a.5.5 0 0 1-.06.67l-6 5.5-.07.05a.5.5 0 0 1-.6-.79L8.75 9l-5.6-5.13-.06-.07a.5.5 0 0 1 .03-.64zm5 0a.5.5 0 0 1 .7-.03l6 5.5.07.07a.5.5 0 0 1-.06.67l-6 5.5-.07.05a.5.5 0 0 1-.6-.79L13.75 9l-5.6-5.13-.06-.07a.5.5 0 0 1 .03-.64z"></path></svg></span><a class="sc-1out364-0 hMndXN sc-15604uf-0 lgsULC js_link" data-ga="[[&quot;Permalink meta&quot;,&quot;Channel click&quot;,&quot;https://deadspin.com/basketball/nba&quot;]]" href="https://deadspin.com/basketball/nba"><span class="ov8naf-0 jaLBMG">NBA</span></a></div></div><div class="js_postbottom-waypoint-hook"></div><div class="js_rev-content-placeholder"><div id="rc-widget-f9557b" data-disable-demand="true" data-rc-widget="true" data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="274361"></div></div><div class="sc-1bdg1q0-0 eRJXHT js_sticky-footer"><div class="sc-1bdg1q0-1 wircm js_ad-sticky-footer"></div></div></div></div></main><aside class="ynugv2-2 sc-101yw2y-6 jPPlae"><div class="sc-101yw2y-5 ffdijb"><div id="sidebar_wrapper" class="ynugv2-3 kxHOoc"><div class="sc-1ez0oyg-0 jkLlnx js_sidebar_sticky_container"><div class="sc-1ez0oyg-1 igemXf sidebar-sticky"><div class="sidebar-sticky-children" style="width:100%"><div class="sc-16d6l1x-0 dXjGrN left-top-ad"><div class="ynugv2-1 dpkHcV"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_TOP ad-left-top" data-ad-unit="LEFT_TOP" data-targeting="{&quot;pos&quot;:&quot;left_top&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a73ac-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-top"></span></div></div></div><div class="ynugv2-0 kXvAvi video-html5-wrapper"><div class="sc-1h0epat-0 hykIxg"><div class="sc-1h0epat-1 gRjwiT"><div class="sc-235a11-0 bDMZeP">Watch</div></div><div class="sc-1wkneyl-0 hxLRyg video-html5-playlist" data-playlist="191117,191024,191118" data-current="191117"><div class="video-html5-loaded"><div class="video-html5-player"><div class="lhhce6-0 bVyOPq video-html5 autoplay muted desktop" data-video-id="191117" data-monetizable="true" data-position="sidebar" data-video-title="Who will be the NBA Finals MVP? | The Weigh In" data-video-blog-id="11" data-video-network="deadspin" data-video-duration="127"><video disablepictureinpicture="" muted="" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_362,pg_1,q_60,w_645/50746e996a87656cb8209836cc21d4ec.jpg" width="100%" height="100%" crossorigin="anonymous" preload="none" style="max-height:none"><source data-src="https://vid.kinja.com/prod/191117/191117_240p.mp4" label="240p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_480p.mp4" label="480p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_720p.mp4" label="720p" type="video/mp4"/><source data-src="https://vid.kinja.com/prod/191117/191117_1080p.mp4" label="1080p" type="video/mp4"/><track kind="captions" label="English" src="https://kinja.com/api/videoupload/caption/17184.vtt" srclang="en"/></video><div class="lhhce6-1 bmmbnr advertisement"></div><div class="ag987e-0 ixVloN btn btn-play" role="button">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div><div class="sc-1yhvqfu-2 eQhEAz video-controls"><div class="sc-1yhvqfu-0 jpPsoD play-pause "><svg class="play" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v6l6-3-6-3z" transform="translate(1 1)"></path></svg><svg class="pause" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v6h2v-6h-2zm4 0v6h2v-6h-2z" transform="translate(1 1)"></path></svg></div><div class="sc-1yhvqfu-0 jpPsoD mute-volume"><div class="sc-1yhvqfu-0 jpPsoD mute-unmute muted"><svg class="mute" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M3.34 0l-1.34 2h-2v4h2l1.34 2h.66v-8h-.66zm1.66 1v1c.17 0 .34.02.5.06.86.22 1.5 1 1.5 1.94s-.63 1.72-1.5 1.94c-.16.04-.33.06-.5.06v1c.25 0 .48-.04.72-.09h.03c1.3-.33 2.25-1.51 2.25-2.91 0-1.4-.95-2.58-2.25-2.91-.23-.06-.49-.09-.75-.09zm0 2v2c.09 0 .18-.01.25-.03.43-.11.75-.51.75-.97 0-.46-.31-.86-.75-.97-.08-.02-.17-.03-.25-.03z"></path></svg><svg class="unmute" xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M3.34 0l-1.34 2h-2v4h2l1.34 2h.66v-8h-.66z" transform="translate(2)"></path></svg></div><div class="sc-1yhvqfu-1 ZmLTq volume"><progress min="0" max="100" value="80"></progress></div></div><div class="sc-1yhvqfu-1 ZmLTq progress"><progress min="0" max="127" value="0"></progress></div><div class="sc-1yhvqfu-0 jpPsoD duration"></div><div class="sc-1yhvqfu-0 jpPsoD fullscreen"><svg xmlns="http://www.w3.org/2000/svg" width="8" height="8" viewBox="0 0 8 8"><path d="M0 0v4l1.5-1.5 1.5 1.5 1-1-1.5-1.5 1.5-1.5h-4zm5 4l-1 1 1.5 1.5-1.5 1.5h4v-4l-1.5 1.5-1.5-1.5z"></path></svg></div><div class="sc-1yhvqfu-0 jpPsoD closed-captions"><button class="cc" type="button">CC</button><ul><li class="selected" data-label="">Off</li><li class="" data-label="English">English</li></ul></div></div></div></div><div class="video-html5-info"><div><div class="sc-1ltrdwy-0 dYjpmh"><a class="sc-1out364-0 hMndXN sc-1ltrdwy-1 kUjuXJ js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;Title click&quot;,&quot;kinjavideo-191117&quot;]]" href="https://deadspin.com/who-will-be-the-nba-finals-mvp-the-weigh-in-1849066153" data-key="permalink"><span data-key="title" class="sc-1ltrdwy-2 clJTGM">Who will be the NBA Finals MVP? | The Weigh In</span></a></div></div></div></div><div class="video-html5-thumbs"><div class="sc-14ojfpu-6 ekJydD"><div data-key="191024" class="sc-14ojfpu-5 jdlHci"><a class="sc-1out364-0 hMndXN sc-14ojfpu-4 hRbPxS js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;click - position 1 of 2&quot;,&quot;kinjavideo-191024&quot;]]" href="https://deadspin.com/a-march-madness-style-nba-playoff-would-change-history-1849023676"><div class="sc-1v01hk4-1 eDBID"><div class="sc-1v01hk4-0 itJsme"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/4911cffa4f4d86e37f495e004adac8f6.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_78,pg_1,q_60,w_140/4911cffa4f4d86e37f495e004adac8f6.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_149,pg_1,q_60,w_265/4911cffa4f4d86e37f495e004adac8f6.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_191,pg_1,q_60,w_340/4911cffa4f4d86e37f495e004adac8f6.jpg 340w" alt="" draggable="auto" data-chomp-id="4911cffa4f4d86e37f495e004adac8f6" data-format="jpg" data-alt="" data-anim-src=""/></div><div class="sc-4cqztc-0 kVwmYN">01:49</div></div><div class="sc-1v01hk4-2 evhnTd"><div class="sc-1v01hk4-3 jolTTN">Now playing</div></div><div class="ag987e-0 sc-1v01hk4-4 fPBAtf">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div></div><div class="sc-14ojfpu-2 innqYa"><div class="sc-14ojfpu-0 hrWYNy">A March Madness-style NBA playoff would change history</div><div class="sc-14ojfpu-1 eqLCCh">June 6, 2022</div></div></a></div><div data-key="191118" class="sc-14ojfpu-5 jdlHci"><a class="sc-1out364-0 hMndXN sc-14ojfpu-4 hRbPxS js_link" data-ga="[[&quot;Video Player Interaction&quot;,&quot;click - position 2 of 2&quot;,&quot;kinjavideo-191118&quot;]]" href="https://deadspin.com/top-5-single-digit-scorers-in-nba-history-1849066959"><div class="sc-1v01hk4-1 eDBID"><div class="sc-1v01hk4-0 itJsme"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,pg_1,q_80,w_80/17d7f6a2c61eb57703e6c0c308c621f8.jpg 80w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_78,pg_1,q_60,w_140/17d7f6a2c61eb57703e6c0c308c621f8.jpg 140w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_149,pg_1,q_60,w_265/17d7f6a2c61eb57703e6c0c308c621f8.jpg 265w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,g_center,h_191,pg_1,q_60,w_340/17d7f6a2c61eb57703e6c0c308c621f8.jpg 340w" alt="" draggable="auto" data-chomp-id="17d7f6a2c61eb57703e6c0c308c621f8" data-format="jpg" data-alt="" data-anim-src=""/></div><div class="sc-4cqztc-0 kVwmYN">02:01</div></div><div class="sc-1v01hk4-2 evhnTd"><div class="sc-1v01hk4-3 jolTTN">Now playing</div></div><div class="ag987e-0 sc-1v01hk4-4 fPBAtf">
	<div class="icon-wrapper">
		<svg class="icon" width="64" height="64" viewBox="0 0 64 64" xmlns="http://www.w3.org/2000/svg" aria-label="Play icon">
			<polygon fill="white" points="20.846 12.913 50 31.634 21 50"/>
		</svg>
	</div>
</div></div><div class="sc-14ojfpu-2 innqYa"><div class="sc-14ojfpu-0 hrWYNy">Top 5 single digit scorers in NBA history</div><div class="sc-14ojfpu-1 eqLCCh">June 15, 2022</div></div></a></div></div></div></div></div></div><div id="commerce-inset-wrapper" style="min-height:350px;max-width:350px;margin-left:auto;margin-right:auto;margin-top:32px" class="sc-16d6l1x-1 ioQMza"><div id="js_commerceInsetModule" data-commerce-insets="[{&quot;id&quot;:&quot;11692&quot;,&quot;productTitle&quot;:&quot;Tushy Classic 3.0 Bidet Toilet Seat Attachment&quot;,&quot;productImage&quot;:{&quot;id&quot;:&quot;63fd5c9752f9ee8efe614cb962f5a4b2&quot;,&quot;format&quot;:&quot;jpg&quot;,&quot;isAnimated&quot;:false,&quot;frozenFormat&quot;:&quot;jpg&quot;},&quot;headline&quot;:&quot;Save a Ton of Toilet Paper and $22 When Buying the Tushy Classic 3.0 Bidet&quot;,&quot;affiliate&quot;:&quot;Amazon&quot;,&quot;embargoDate&quot;:&quot;&quot;,&quot;expirationDate&quot;:&quot;&quot;,&quot;insetContent&quot;:[{&quot;label&quot;:&quot;Switch to a bidet today!&quot;,&quot;text&quot;:&quot;Wiping over and over with paper is no way to get yourself clean.&quot;}],&quot;insetLabel&quot;:&quot;&quot;,&quot;partnerLinks&quot;:[{&quot;vendor&quot;:&quot;Buy for $87 at Amazon&quot;,&quot;url&quot;:&quot;https://www.amazon.com/Tushy-Classic-Bidet-Toilet-Attachment/dp/B08VS11Z1N?ots=1&amp;slotNum=1&amp;imprToken=3cc297f8-1ad4-aa32-fdd&amp;asc_campaign=kinjainventorylink-20&amp;asc_refurl=https://theinventory.com/save-a-ton-of-toilet-paper-and-22-when-buying-the-tush-1849914163&amp;asc_source=&amp;tag=kinjainventorylink-20&quot;,&quot;discountPrice&quot;:null,&quot;discountCode&quot;:null}],&quot;position&quot;:{&quot;blogId&quot;:&quot;11&quot;,&quot;position&quot;:1,&quot;pinned&quot;:true},&quot;insetSubHead&quot;:&quot;The Tushy Classic 3.0 bidet attachment is 20% off.&quot;,&quot;slug&quot;:&quot;20% off&quot;,&quot;creativeType&quot;:&quot;B&quot;,&quot;variativeCommerceSettings&quot;:{&quot;topImage&quot;:{&quot;id&quot;:&quot;fcff13e1e14f7b3a2a7818103a83e3f6&quot;,&quot;format&quot;:&quot;png&quot;},&quot;toutImage&quot;:{&quot;id&quot;:&quot;19a9a3f85ee515bc0822e28bde781e1f&quot;,&quot;format&quot;:&quot;png&quot;},&quot;toutText&quot;:&quot;20% off&quot;}},{&quot;id&quot;:&quot;10793&quot;,&quot;productTitle&quot;:&quot;Amazon Music Unlimited - Three Months Free&quot;,&quot;productImage&quot;:{&quot;id&quot;:&quot;3eadbb55ead557fda61f79813bf0d834&quot;,&quot;format&quot;:&quot;png&quot;,&quot;isAnimated&quot;:false,&quot;frozenFormat&quot;:&quot;png&quot;},&quot;headline&quot;:&quot;&quot;,&quot;affiliate&quot;:null,&quot;embargoDate&quot;:&quot;&quot;,&quot;expirationDate&quot;:&quot;&quot;,&quot;insetContent&quot;:[{&quot;label&quot;:&quot;Three months of HD audio for free&quot;,&quot;text&quot;:&quot;Stream HD, ad-free music and your absolute favorite podcasts for three months free for new users.&quot;}],&quot;insetLabel&quot;:&quot;&quot;,&quot;partnerLinks&quot;:[{&quot;vendor&quot;:&quot;Sign up with your Prime Membership at Amazon&quot;,&quot;url&quot;:&quot;https://www.amazon.com/music/unlimited&quot;,&quot;discountPrice&quot;:null,&quot;discountCode&quot;:null},{&quot;vendor&quot;:&quot;Buy the Echo Dot for $1 when you Subscribe to Amazon Music Unlimited at Amazon&quot;,&quot;url&quot;:&quot;https://www.amazon.com/b/?node=21390537011&quot;,&quot;discountPrice&quot;:null,&quot;discountCode&quot;:null},{&quot;vendor&quot;:&quot;Get Amazon Music Unlimited Free when you Buy Select Echo Devices at Amazon&quot;,&quot;url&quot;:&quot;https://www.amazon.com/b?ie=UTF8&amp;node=23477595011&quot;,&quot;discountPrice&quot;:null,&quot;discountCode&quot;:null}],&quot;position&quot;:{&quot;position&quot;:2,&quot;pinned&quot;:true},&quot;insetSubHead&quot;:&quot;&quot;,&quot;slug&quot;:&quot;let&#x27;s groove&quot;,&quot;creativeType&quot;:&quot;A&quot;,&quot;variativeCommerceSettings&quot;:null}]"></div></div><div id="trending_wrapper" class="ynugv2-0 hVUnIE"><div id="js_trending" class="cls" data-posts="[&quot;1849915387&quot;,&quot;1849913028&quot;,&quot;1849915321&quot;]" data-remove-h-tags="true" data-page-type="permalink" data-max-posts="3" data-blog-id="11"></div></div><div id="js_alerts_sidebar"></div><div class="bwfnz4-2 fFIbbh"><div class="sc-1ez0oyg-0 fwCBOs"><div class="sc-1ez0oyg-1 igemYY"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_RAIL ad-left-rail" data-ad-unit="LEFT_RAIL" data-targeting="{&quot;pos&quot;:&quot;left&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a6193-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-rail"></span></div></div></div></div></div></div></div><div class="ynugv2-0 cySkyK js_moreFromNetwork"><div id="js_moreFromNetwork" data-posts="[&quot;1849865844&quot;,&quot;1849849471&quot;,&quot;1848191533&quot;]" data-remove-h-tags="true"></div></div><div class="js_newsletter-container"></div><div id="leftrail_dynamic_ad_wrapper"><div class="bwfnz4-1 bzcmiQ"><div id="1671575909328" class="bwfnz4-2 fFIbbh"><div><div><div class="sc-1ez0oyg-0 fwCBOs"><div class="sc-1ez0oyg-1 igemYY"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_RAIL_DYNAMIC ad-left-rail dfp-left-rail-dynamic" data-ad-unit="LEFT_RAIL_DYNAMIC" data-targeting="{&quot;pos&quot;:&quot;left_dynamic&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a672c-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-rail dfp-left-rail-dynamic"></span></div></div></div></div></div></div><div class="bwfnz4-2 fFIbbh"><div class="bwfnz4-0 ciErkt"></div></div></div></div></div></div></aside></div><div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-INFINITE_PROMOTION ad-infinite-promotion" data-ad-unit="INFINITE_PROMOTION" data-pp-position="scroll" data-targeting="{&quot;pos&quot;:&quot;scroll&quot;,&quot;pp_position&quot;:&quot;scroll&quot;}"></div><div class="sc-1f135w2-0 AyvBi js_reading-list"></div></div><div class="sc-1cfejv7-0 hLOPcM js_subscribe"></div><div class="js_footer-container"></div><div class="js_lightbox-container"></div></div></div><script id="render-data" type="application/json">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</script><script async="" src="/x-kinja-static/assets/new-client/runtime~trackers.7bba3acb089af9e60d01.js"></script><script async="" src="/x-kinja-static/assets/new-client/vendor~carGalleryPage~curatedHomepage~featureSwitchPageClient~frontPage~modify-commerce-links~search~3077f038.52cfdc0d53ed4d2a8559.js"></script><script async="" src="/x-kinja-static/assets/new-client/vendor~trackers.75f5fc5fcad7193f8229.js"></script><script async="" src="/x-kinja-static/assets/new-client/second-scroll~trackers.f5c415ef86359382482b.js"></script><script async="" src="/x-kinja-static/assets/new-client/trackers.92706734d66bf6f236d0.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/runtime~permalinkPage.f7fbbea236cede0a8752.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~dc151c4a.bc65a346bfe89a689b8f.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~7dd5981a.c78d385ab1296c320bbc.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~07b3ecb1.196fe590ce3e6704fe97.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~5a2cb425.87986c4e31eb5eaba09e.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~f7b2c535.365f26579ec4383f604d.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~alertsUnsubscribePage~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channel~2f1d040a.f2a45a76a84a6d4a4bba.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channelSectionPage~commerceDa~bbebe675.26a8dda813f24126ac14.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~adEditor~biztoolsPage~carGalleryPage~carSpecsPage~celebrityPage~channelSectionPage~commerceDa~b51ab3d8.fee092e2ae29cf5d9855.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/adEditor~biztoolsPage~carSpecsPage~commerceDashboard~curatedHomepage~curatedPostsPage~datadog~errorP~c78bae6b.fb3c171454a84257ce6c.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/adEditor~biztoolsPage~carSpecsPage~commerceDashboard~curatedHomepage~curatedPostsPage~errorPage~feat~9220b0d7.376dea79fa1571f7bd75.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/adEditor~biztoolsPage~carSpecsPage~commerceDashboard~curatedHomepage~curatedPostsPage~errorPage~feat~bf312e79.80a540aeefd7d8cb5beb.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/adEditor~biztoolsPage~carSpecsPage~commerceDashboard~curatedPostsPage~embiggen~errorPage~featureSwit~a957c0c6.d9078328147e1e839631.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/YMALModule~adEditorComponent~car-comparator~car-selector~featuredPermalinkPage~follow-controls~foote~df0dfb5f.fbdab1d2ce0906c66978.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/biztoolsPage~carSpecsPage~commerceDashboard~curatedPostsPage~errorPage~featureSwitchPage~featuredPer~93d5e25f.9c6330707efb5f757f49.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/biztoolsPage~carSpecsPage~commerceDashboard~errorPage~featureSwitchPage~featuredPermalinkPage~permal~daad1d43.8fe20a41a5f8199162bd.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/permalinkPage.2eaea59a7d4c40274af1.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/runtime~datadog.57723a74e78b2ea0fa67.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~browser-logs~datadog.f87c923ffc3ec082e0b5.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendor~datadog.a660458f7be91ee17a67.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/biztoolsPage~carSpecsPage~commerceDashboard~datadog~errorPage~featureSwitchPage~profilePage~splashPa~b0e1c94f.fa741c67330862609eba.js"></script><script id="datadog-script" async="" data-src="//x.kinja-static.com/assets/new-client/datadog.e160637a4631405440b4.js"></script><script>
							if (Math.random() < 0.002) {
								const datadogScript = document.getElementById('datagod-script');
								if (datadogScript) {
									datadogScript.setAttribute('src', datadogScript.getAttribute('data-src'));
								}
							}
						</script><div class="js_modal_exit_intent"></div><div class="js_modal"></div><div id="kinja-bucket-setter"></div></body></html>